Cisco IOS XE – RSVP L3VPN

We have done a L2VPN on IOS XE so lets give a L3VPN a try. RSVP is used for signalling, IS-IS for the IGP and P1 acting as a route reflector. 2 Cisco CE devices with OSPF configured to the PEs. Will throw in an OSPF sham link for a bit of fun.

https://www.cisco.com/c/en/us/td/docs/ios-xml/ios/mp_l3_vpns/configuration/xe-17/mp-l3-vpns-xe-17-book.html

PE1

hostname pe1

ip vrf CE1
rd 5.5.5.5:100
route-target export 65200:100
route-target import 65200:100

mpls traffic-eng tunnels
  
interface Loopback0
ip address 5.5.5.5 255.255.255.255
ip router isis 1
isis circuit-type level-2-only

interface Loopback1
ip vrf forwarding CE1
ip address 22.22.22.22 255.255.255.255

interface Tunnel1
ip unnumbered Loopback0
tunnel mode mpls traffic-eng
tunnel destination 7.7.7.7
tunnel mpls traffic-eng autoroute announce
tunnel mpls traffic-eng path-option 1 dynamic

interface GigabitEthernet1
ip address 1.1.1.1 255.255.255.252
ip router isis 1
mpls ip
mpls traffic-eng tunnels
isis circuit-type level-2-only
isis network point-to-point
ip rsvp bandwidth percent 50
ip rsvp signalling hello

interface GigabitEthernet2
ip vrf forwarding CE1
ip address 10.1.1.1 255.255.255.0
ip ospf 1 area 0
  
router ospf 1 vrf CE1
area 0 sham-link 22.22.22.22 33.33.33.33
redistribute bgp 65200

router isis 1
net 49.0000.5555.5555.5555.00
is-type level-2-only
metric-style wide
mpls traffic-eng router-id Loopback0
mpls traffic-eng level-2

router bgp 65200
bgp log-neighbor-changes
neighbor 6.6.6.6 remote-as 65200
neighbor 6.6.6.6 update-source Loopback0

address-family vpnv4
neighbor 6.6.6.6 activate
neighbor 6.6.6.6 send-community extended
exit-address-family

address-family ipv4 vrf CE1
network 22.22.22.22 mask 255.255.255.255
redistribute ospf 1
exit-address-family

P1

hostname p1

mpls traffic-eng tunnels
  
interface Loopback0
ip address 6.6.6.6 255.255.255.255
ip router isis 1
isis circuit-type level-2-only

interface GigabitEthernet1
ip address 1.1.1.2 255.255.255.252
ip router isis 1
mpls ip
mpls traffic-eng tunnels
isis circuit-type level-2-only
isis network point-to-point
ip rsvp bandwidth percent 50
ip rsvp signalling hello

interface GigabitEthernet2
ip address 2.2.2.1 255.255.255.252
ip router isis 1
mpls ip
mpls traffic-eng tunnels
isis circuit-type level-2-only
isis network point-to-point
ip rsvp bandwidth percent 50
ip rsvp signalling hello

router isis 1
net 49.0000.6666.6666.6666.00
is-type level-2-only
metric-style wide
mpls traffic-eng router-id Loopback0
mpls traffic-eng level-2

router bgp 65200
bgp log-neighbor-changes
neighbor 5.5.5.5 remote-as 65200
neighbor 5.5.5.5 update-source Loopback0
neighbor 7.7.7.7 remote-as 65200
neighbor 7.7.7.7 update-source Loopback0

address-family vpnv4
neighbor 5.5.5.5 activate
neighbor 5.5.5.5 send-community extended
neighbor 5.5.5.5 route-reflector-client
neighbor 7.7.7.7 activate
neighbor 7.7.7.7 send-community extended
neighbor 7.7.7.7 route-reflector-client
exit-address-family

PE2

hostname pe2

ip vrf CE2
rd 7.7.7.7:100
route-target export 65200:100
route-target import 65200:100

mpls traffic-eng tunnels
  
interface Loopback0
ip address 7.7.7.7 255.255.255.255
ip router isis 1
isis circuit-type level-2-only
  
interface Loopback1
ip vrf forwarding CE2
ip address 33.33.33.33 255.255.255.255

interface Tunnel1
ip unnumbered Loopback0
tunnel mode mpls traffic-eng
tunnel destination 5.5.5.5
tunnel mpls traffic-eng autoroute announce
tunnel mpls traffic-eng path-option 1 dynamic

interface GigabitEthernet1
ip address 2.2.2.2 255.255.255.252
ip router isis 1
mpls ip
mpls traffic-eng tunnels
isis circuit-type level-2-only
isis network point-to-point
ip rsvp bandwidth percent 50
ip rsvp signalling hello

interface GigabitEthernet2
ip vrf forwarding CE2
ip address 10.2.2.1 255.255.255.0
ip ospf 1 area 0
  
router ospf 1 vrf CE2
router-id 10.2.2.1
area 0 sham-link 33.33.33.33 22.22.22.22
redistribute bgp 65200

router isis 1
net 49.0000.7777.7777.7777.00
is-type level-2-only
metric-style wide
mpls traffic-eng router-id Loopback0
mpls traffic-eng level-2

router bgp 65200
bgp log-neighbor-changes
neighbor 6.6.6.6 remote-as 65200
neighbor 6.6.6.6 update-source Loopback0

address-family vpnv4
neighbor 6.6.6.6 activate
neighbor 6.6.6.6 send-community extended
exit-address-family

address-family ipv4 vrf CE2
network 33.33.33.33 mask 255.255.255.255
redistribute ospf 1
exit-address-family

The L3VPN will now be up and you can confirm by checking the routing tables of the CE devices. In this instance the sham links were configured with IP addresses of 22.22.22.22/32 & 33.33.33.33/32.

Cisco IOS XE – Segment Routing VPLS

Instead of using LDP or RSVP, IS-IS Segment Routing is used. P1 acts as a route reflector. A simple lab with, as usual, 2 Cisco CE devices. EIGRP is used between them instead of OSPF.

https://www.cisco.com/c/en/us/td/docs/ios-xml/ios/seg_routing/configuration/xe-17/segrt-xe-17-book/m_sr-ospf.html

PE1

hostname pe1

l2 vfi VPLS autodiscovery
vpn id 444
bridge-domain 1
rd 5.5.5.5:444
route-target export 65200:444
route-target import 65200:444
  
interface Loopback0
ip address 5.5.5.5 255.255.255.255
ip router isis 1

interface GigabitEthernet1
ip address 1.1.1.1 255.255.255.252
ip router isis 1
negotiation auto
no mpls ldp igp autoconfig
no mop enabled
no mop sysid
isis circuit-type level-2-only
isis network point-to-point

interface GigabitEthernet2
no ip address
negotiation auto
no mop enabled
no mop sysid
service instance 1 ethernet
encapsulation dot1q 444
bridge-domain 1

segment-routing mpls
set-attributes
address-family ipv4
sr-label-preferred
exit-address-family

global-block 40000 45000

connected-prefix-sid-map
address-family ipv4
5.5.5.5/32 index 100 range 1
exit-address-family


router isis 1
net 49.0000.5555.5555.5555.00
is-type level-2-only
metric-style wide
segment-routing mpls

router bgp 65200
bgp log-neighbor-changes
neighbor 6.6.6.6 remote-as 65200
neighbor 6.6.6.6 update-source Loopback0

address-family ipv4
neighbor 6.6.6.6 activate
exit-address-family

address-family l2vpn vpls
neighbor 6.6.6.6 activate
neighbor 6.6.6.6 send-community extended
neighbor 6.6.6.6 next-hop-self

P1

hostname p1
  
interface Loopback0
ip address 6.6.6.6 255.255.255.255
ip router isis 1

interface GigabitEthernet1
ip address 1.1.1.2 255.255.255.252
ip router isis 1
negotiation auto
no mpls ldp igp autoconfig
no mop enabled
no mop sysid
isis circuit-type level-2-only
isis network point-to-point

interface GigabitEthernet2
ip address 2.2.2.1 255.255.255.252
ip router isis 1
negotiation auto
no mpls ldp igp autoconfig
no mop enabled
no mop sysid
isis circuit-type level-2-only
isis network point-to-point
  
segment-routing mpls
set-attributes
address-family ipv4
sr-label-preferred
exit-address-family

global-block 40000 45000

connected-prefix-sid-map
address-family ipv4
6.6.6.6/32 index 200 range 1
exit-address-family


router isis 1
net 49.0000.6666.6666.6666.00
is-type level-2-only
metric-style wide
segment-routing mpls

router bgp 65200
bgp log-neighbor-changes
neighbor 5.5.5.5 remote-as 65200
neighbor 5.5.5.5 update-source Loopback0
neighbor 7.7.7.7 remote-as 65200
neighbor 7.7.7.7 update-source Loopback0

address-family ipv4
neighbor 5.5.5.5 activate
neighbor 7.7.7.7 activate
exit-address-family

address-family l2vpn vpls
neighbor 5.5.5.5 activate
neighbor 5.5.5.5 send-community extended
neighbor 5.5.5.5 route-reflector-client
neighbor 7.7.7.7 activate
neighbor 7.7.7.7 send-community extended
neighbor 7.7.7.7 route-reflector-client

PE2

hostname pe2

l2 vfi VPLS autodiscovery
vpn id 444
bridge-domain 1
rd 7.7.7.7:444
route-target export 65200:444
route-target import 65200:444

interface Loopback0
ip address 7.7.7.7 255.255.255.255
ip router isis 1

interface GigabitEthernet1
ip address 2.2.2.2 255.255.255.252
ip router isis 1
negotiation auto
no mpls ldp igp autoconfig
no mop enabled
no mop sysid
isis circuit-type level-2-only
isis network point-to-point

interface GigabitEthernet2
no ip address
negotiation auto
no mop enabled
no mop sysid
service instance 1 ethernet
encapsulation dot1q 444
bridge-domain 1

segment-routing mpls
set-attributes
address-family ipv4
sr-label-preferred
exit-address-family

global-block 40000 45000

connected-prefix-sid-map
address-family ipv4
7.7.7.7/32 index 300 range 1
exit-address-family

router isis 1
net 49.0000.7777.7777.7777.00
is-type level-2-only
metric-style wide
segment-routing mpls

router bgp 65200
bgp log-neighbor-changes
neighbor 6.6.6.6 remote-as 65200
neighbor 6.6.6.6 update-source Loopback0

address-family ipv4
neighbor 6.6.6.6 activate
exit-address-family

address-family l2vpn vpls
neighbor 6.6.6.6 activate
neighbor 6.6.6.6 send-community extended
neighbor 6.6.6.6 next-hop-self

EIGRP is now up between the 2 CE devices confirming VPLS is up and running

Cisco IOS XE – MPLS EVPN

IS-IS is used for the underlay. The 2 CEs are Cisco vIOS switches with VLAN 2222 and OSPF configured on them.

https://www.cisco.com/c/en/us/td/docs/routers/ios/config/17-x/mpls/b-mpls/m-evpn-over-mpls.html

PE1

hostname pe1
  
mpls label protocol ldp
l2vpn evpn
replication-type ingress
mpls label mode per-ce
router-id Loopback0

l2vpn evpn instance 1 vlan-based
route-target export 65200:1
route-target import 65200:1
no auto-route-target

bridge-domain 1
member GigabitEthernet2 service-instance 1
member evpn-instance 1
  
interface Loopback0
ip address 5.5.5.5 255.255.255.255
ip router isis 1

interface GigabitEthernet1
ip address 1.1.1.1 255.255.255.252
ip router isis 1
mpls ip

interface GigabitEthernet2
no ip address
service instance 1 ethernet
encapsulation dot1q 2222
  
router isis 1
net 49.0000.5555.5555.5555.00

router bgp 65200
bgp router-id 5.5.5.5
bgp log-neighbor-changes
neighbor 9.9.9.9 remote-as 65200
neighbor 9.9.9.9 update-source Loopback0

address-family ipv4
neighbor 9.9.9.9 activate
exit-address-family

address-family l2vpn evpn
neighbor 9.9.9.9 activate
neighbor 9.9.9.9 send-community both
exit-address-family

P1

hostname p1

mpls label protocol ldp
  
interface Loopback0
ip address 6.6.6.6 255.255.255.255
ip router isis 1

interface GigabitEthernet1
ip address 1.1.1.2 255.255.255.252
ip router isis 1
mpls ip

interface GigabitEthernet2
ip address 2.2.2.1 255.255.255.252
ip router isis 1
mpls ip

router isis 1
net 49.0000.6666.6666.6666.00

P2

hostname p2

mpls label protocol ldp
  
interface Loopback0
ip address 7.7.7.7 255.255.255.255
ip router isis 1

interface GigabitEthernet1
ip address 2.2.2.2 255.255.255.252
ip router isis 1
mpls ip

interface GigabitEthernet2
ip address 3.3.3.1 255.255.255.252
ip router isis 1
mpls ip

router isis 1
net 49.0000.7777.7777.7777.00

P3

hostname p3

mpls label protocol ldp
  
interface Loopback0
ip address 8.8.8.8 255.255.255.255
ip router isis 1

interface GigabitEthernet1
ip address 3.3.3.2 255.255.255.252
ip router isis 1
mpls ip

interface GigabitEthernet2
ip address 4.4.4.1 255.255.255.252
ip router isis 1
mpls ip

router isis 1
net 49.0000.8888.8888.8888.00

PE2

hostname pe2
  
mpls label protocol ldp

l2vpn evpn
replication-type ingress
mpls label mode per-ce
router-id Loopback0

l2vpn evpn instance 1 vlan-based
route-target export 65200:1
route-target import 65200:1
no auto-route-target

bridge-domain 1
member GigabitEthernet2 service-instance 1
member evpn-instance 1
  
interface Loopback0
ip address 9.9.9.9 255.255.255.255
ip router isis 1

interface GigabitEthernet1
ip address 4.4.4.2 255.255.255.252
ip router isis 1
mpls ip

interface GigabitEthernet2
no ip address
service instance 1 ethernet
encapsulation dot1q 2222
  
router isis 1
net 49.0000.9999.9999.9999.00

router bgp 65200
bgp router-id 9.9.9.9
bgp log-neighbor-changes
neighbor 5.5.5.5 remote-as 65200
neighbor 5.5.5.5 update-source Loopback0

address-family ipv4
neighbor 5.5.5.5 activate
exit-address-family

address-family l2vpn evpn
neighbor 5.5.5.5 activate
neighbor 5.5.5.5 send-community both
exit-address-family

OSPF will now be up between the 2 CEs and MAC addresses being learnt on the 2 PE devices.

Cisco IOS-XE EVPN/VPWS

Aim of this lab is to create a layer 2 circuit between switch6 & switch7 and form an OSPF adjacency. IS-IS is used for the underlay as it’s better (it really is!).

https://www.cisco.com/c/en/us/td/docs/ios-xml/ios/mp_l2_vpns/configuration/xe-3s/asr903/mp-l2-vpns-xe-3s-asr903-book/epvn_vpws_single_homed.html

CSR1

conf t
hostname csr1
mpls label protocol ldp
l2vpn evpn logging vc-state
l2vpn
router-id 5.5.5.5

interface Loopback0
ip address 5.5.5.5 255.255.255.255
ip router isis 1

interface GigabitEthernet1
ip address 1.1.1.1 255.255.255.252
ip router isis 1
mpls ip

interface GigabitEthernet2
no ip address
service instance 1 ethernet
encapsulation dot1q 1000
rewrite ingress tag pop 1 symmetric
  
router isis 1
net 49.0000.5555.5555.5555.00

router bgp 65200
bgp log-neighbor-changes
neighbor 6.6.6.6 remote-as 65200
neighbor 6.6.6.6 update-source Loopback0

address-family ipv4
neighbor 6.6.6.6 activate
exit-address-family

address-family l2vpn evpn
neighbor 6.6.6.6 activate
exit-address-family

l2vpn evpn instance 1 point-to-point

vpws context cust1
service target 1 source 2
member GigabitEthernet2 service-instance 1

CSR2

conf t
hostname csr2
mpls label protocol ldp
  
interface Loopback0
ip address 6.6.6.6 255.255.255.255
ip router isis 1
  
interface GigabitEthernet1
ip address 1.1.1.2 255.255.255.252
ip router isis 1
mpls ip

interface GigabitEthernet2
ip address 2.2.2.1 255.255.255.252
ip router isis 1
mpls ip
  
router isis 1
net 49.0000.6666.6666.6666.00

router bgp 65200
bgp log-neighbor-changes
neighbor 5.5.5.5 remote-as 65200
neighbor 5.5.5.5 update-source Loopback0
neighbor 7.7.7.7 remote-as 65200
neighbor 7.7.7.7 update-source Loopback0

address-family ipv4
neighbor 5.5.5.5 activate
neighbor 7.7.7.7 activate
exit-address-family

address-family l2vpn evpn
neighbor 5.5.5.5 activate
neighbor 5.5.5.5 route-reflector-client
neighbor 7.7.7.7 activate
exit-address-family

CSR3

conf t
hostname csr3
mpls label protocol ldp

interface Loopback0
ip address 7.7.7.7 255.255.255.255
ip router isis 1

interface GigabitEthernet1
ip address 2.2.2.2 255.255.255.252
ip router isis 1
mpls ip

interface GigabitEthernet2
ip address 3.3.3.1 255.255.255.252
ip router isis 1
mpls ip
  
router isis 1
net 49.0000.7777.7777.7777.00

router bgp 65200
bgp log-neighbor-changes
neighbor 6.6.6.6 remote-as 65200
neighbor 6.6.6.6 update-source Loopback0
neighbor 8.8.8.8 remote-as 65200
neighbor 8.8.8.8 update-source Loopback0

address-family ipv4
neighbor 6.6.6.6 activate
neighbor 8.8.8.8 activate
exit-address-family

address-family l2vpn evpn
neighbor 6.6.6.6 activate
neighbor 6.6.6.6 route-reflector-client
neighbor 8.8.8.8 activate
neighbor 8.8.8.8 route-reflector-client
exit-address-family

CSR4

conf t
hostname csr4
mpls label protocol ldp
  
interface Loopback0
ip address 8.8.8.8 255.255.255.255
ip router isis 1

interface GigabitEthernet1
ip address 3.3.3.2 255.255.255.252
ip router isis 1
mpls ip
 
interface GigabitEthernet2
ip address 4.4.4.1 255.255.255.252
ip router isis 1
mpls ip
  
router isis 1
net 49.0000.8888.8888.8888.00
  
router bgp 65200
bgp log-neighbor-changes
neighbor 7.7.7.7 remote-as 65200
neighbor 7.7.7.7 update-source Loopback0
neighbor 9.9.9.9 remote-as 65200
neighbor 9.9.9.9 update-source Loopback0

address-family ipv4
neighbor 7.7.7.7 activate
neighbor 9.9.9.9 activate
exit-address-family

address-family l2vpn evpn
neighbor 7.7.7.7 activate
neighbor 9.9.9.9 activate
neighbor 9.9.9.9 route-reflector-client
exit-address-family

CSR5

conf t
hostname csr5
mpls label protocol ldp
l2vpn
router-id 9.9.9.9
  
interface Loopback0
ip address 9.9.9.9 255.255.255.255
ip router isis 1

interface GigabitEthernet1
ip address 4.4.4.2 255.255.255.252
ip router isis 1
mpls ip
  
interface GigabitEthernet2
no ip address
service instance 1 ethernet
encapsulation dot1q 1000
rewrite ingress tag pop 1 symmetric

router isis 1
net 49.0000.9999.9999.9999.00

router bgp 65200
bgp log-neighbor-changes
neighbor 8.8.8.8 remote-as 65200
neighbor 8.8.8.8 update-source Loopback0

address-family ipv4
neighbor 8.8.8.8 activate
exit-address-family
 
address-family l2vpn evpn
neighbor 8.8.8.8 activate
exit-address-family

mpls ldp router-id Loopback0
l2vpn evpn instance 1 point-to-point

vpws context cust1
service target 2 source 1
member GigabitEthernet2 service-instance 1

Once all devices configured, run ‘show l2vpn evpn vc id 1‘ to confirm circuit is up and then configure OSPF on your CE devices (use whatever you prefer) and the adjacency will come up.

Cisco IOS-XR – L3VPN

Topology below. Juniper vMX devices used as CE’s but you are free to use whatever you would like. BGP is used between PE’s & CE’s but you could use another protocol if you prefer. The MPLS core has an iBGP session between PE1 & PE2 but you could build BGP throughout and use Route Reflectors.

https://www.cisco.com/c/en/us/td/docs/ios_xr_sw/iosxr_r3-7/mpls/configuration/guide/gc37v3.html

PE1

hostname pe1

vrf cust1
address-family ipv4 unicast
import route-target 65400:1
export route-target 65400:1

interface Loopback0
ipv4 address 5.5.5.5 255.255.255.255
  
interface GigabitEthernet0/0/0/0
ipv4 address 1.1.1.1 255.255.255.252

interface GigabitEthernet0/0/0/1
vrf cust1
ipv4 address 10.1.1.1 255.255.255.252

route-policy ALL
pass

router isis 1
is-type level-2-only
net 49.0000.5555.5555.5555.00
address-family ipv4 unicast
interface Loopback0
address-family ipv4 unicast
interface GigabitEthernet0/0/0/0
address-family ipv4 unicast

router bgp 65400
address-family vpnv4 unicast
neighbor 9.9.9.9
remote-as 65400
update-source Loopback0
address-family vpnv4 unicast

vrf cust1
rd 5.5.5.5:1
address-family ipv4 unicast
redistribute connected

neighbor 10.1.1.2
remote-as 65500
update-source GigabitEthernet0/0/0/1
address-family ipv4 unicast
route-policy ALL in
route-policy ALL out
as-override

mpls ldp
interface GigabitEthernet0/0/0/0

P1

hostname p1

interface Loopback0
ipv4 address 6.6.6.6 255.255.255.255
  
interface GigabitEthernet0/0/0/0
ipv4 address 1.1.1.2 255.255.255.252

interface GigabitEthernet0/0/0/1
ipv4 address 2.2.2.1 255.255.255.252

router isis 1
is-type level-2-only
net 49.0000.6666.6666.6666.00
interface Loopback0
address-family ipv4 unicast

interface GigabitEthernet0/0/0/0
address-family ipv4 unicast
!
!
interface GigabitEthernet0/0/0/1
address-family ipv4 unicast
  
mpls ldp
interface GigabitEthernet0/0/0/0
interface GigabitEthernet0/0/0/1

P2

hostname p2

interface Loopback0
ipv4 address 7.7.7.7 255.255.255.255
  
interface GigabitEthernet0/0/0/0
ipv4 address 2.2.2.2 255.255.255.252

interface GigabitEthernet0/0/0/1
ipv4 address 3.3.3.1 255.255.255.252
  
router isis 1
is-type level-2-only
net 49.0000.7777.7777.7777.00
interface Loopback0
address-family ipv4 unicast
interface GigabitEthernet0/0/0/0
address-family ipv4 unicast
interface GigabitEthernet0/0/0/1
address-family ipv4 unicast

mpls ldp
interface GigabitEthernet0/0/0/0
interface GigabitEthernet0/0/0/1

P3

hostname p3
  
interface Loopback0
ipv4 address 8.8.8.8 255.255.255.255
  
interface GigabitEthernet0/0/0/0
ipv4 address 3.3.3.2 255.255.255.252
    
interface GigabitEthernet0/0/0/1
ipv4 address 4.4.4.1 255.255.255.252

router isis 1
is-type level-2-only
net 49.0000.8888.8888.8888.00
interface Loopback0
address-family ipv4 unicast
interface GigabitEthernet0/0/0/0
address-family ipv4 unicast
interface GigabitEthernet0/0/0/1
address-family ipv4 unicast

mpls ldp
interface GigabitEthernet0/0/0/0
interface GigabitEthernet0/0/0/1

PE2

hostname pe2

vrf cust1
address-family ipv4 unicast
import route-target 65400:1
export route-target 65400:1

interface Loopback0
ipv4 address 9.9.9.9 255.255.255.255

interface GigabitEthernet0/0/0/0
ipv4 address 4.4.4.2 255.255.255.252

interface GigabitEthernet0/0/0/1
vrf cust1
ipv4 address 10.10.10.1 255.255.255.252

route-policy ALL
pass

router isis 1
is-type level-2-only
net 49.0000.9999.9999.9999.00
interface Loopback0
address-family ipv4 unicast
interface GigabitEthernet0/0/0/0
address-family ipv4 unicast
  
router bgp 65400
address-family vpnv4 unicast
neighbor 5.5.5.5
remote-as 65400
update-source Loopback0
address-family vpnv4 unicast

vrf cust1
rd 9.9.9.9:1
address-family ipv4 unicast
redistribute connected

neighbor 10.10.10.2
remote-as 65500
update-source GigabitEthernet0/0/0/1
address-family ipv4 unicast
route-policy ALL in
route-policy ALL out
as-override

mpls ldp
interface GigabitEthernet0/0/0/0

Loopback addresses of 11.11.11.11 & 22.22.22.22 have been configured on PE1 & PE2 respectively and you can confirm connectivity through the MPLS core by pinging the loopback from the other PE.