Juniper vMX – IPv6 Tunneling over SR

Quite a simple lab this one. A customer wants to establish IPv6 connectivity between 2 sites over our SR IPv4 core so IPv6 tunneling is required. 2 Cisco vIOS routers used as the CE devices.

https://www.juniper.net/documentation/us/en/software/junos/mpls/topics/topic-map/ipv6-o-ipv4-tunnels.html

PE1

set chassis network-services enhanced-ip
set interfaces ge-0/0/0 unit 0 family inet address 1.1.1.1/30
set interfaces ge-0/0/0 unit 0 family iso
set interfaces ge-0/0/0 unit 0 family inet6
set interfaces ge-0/0/0 unit 0 family mpls
set interfaces ge-0/0/1 unit 0 family inet6 address 2a45:0425:2ca1::0567:5673:23b4/127
set interfaces lo0 unit 0 family inet address 5.5.5.5/32
set interfaces lo0 unit 0 family iso address 49.0000.5555.0000.0000.00
set interfaces lo0 unit 0 family mpls
set policy-options policy-statement BGPv6 from family inet6
set policy-options policy-statement BGPv6 from protocol bgp
set policy-options policy-statement BGPv6 then accept
set policy-options policy-statement V6 from family inet6
set policy-options policy-statement V6 from protocol bgp
set policy-options policy-statement V6 from protocol direct
set policy-options policy-statement V6 then accept
set policy-options policy-statement next-hop-self then next-hop self
set routing-options router-id 5.5.5.5
set routing-options autonomous-system 65400
set protocols bgp group CE1 type external
set protocols bgp group CE1 local-address 2a45:0425:2ca1::0567:5673:23b4
set protocols bgp group CE1 family inet6 unicast
set protocols bgp group CE1 export BGPv6
set protocols bgp group CE1 peer-as 65001
set protocols bgp group CE1 neighbor 2a45:0425:2ca1::0567:5673:23b5
set protocols bgp group V6TUNNEL type internal
set protocols bgp group V6TUNNEL local-address 5.5.5.5
set protocols bgp group V6TUNNEL family inet6 labeled-unicast explicit-null
set protocols bgp group V6TUNNEL export next-hop-self
set protocols bgp group V6TUNNEL export V6
set protocols bgp group V6TUNNEL neighbor 7.7.7.7
set protocols isis source-packet-routing srgb start-label 30000
set protocols isis source-packet-routing srgb index-range 1000
set protocols isis source-packet-routing node-segment ipv4-index 100
set protocols isis level 1 disable
set protocols isis level 2 wide-metrics-only
set protocols isis interface ge-0/0/0.0 point-to-point
set protocols isis interface lo0.0 passive
set protocols mpls ipv6-tunneling
set protocols mpls interface ge-0/0/0.0

P1

set chassis network-services enhanced-ip
set interfaces ge-0/0/0 unit 0 family inet address 1.1.1.2/30
set interfaces ge-0/0/0 unit 0 family iso
set interfaces ge-0/0/0 unit 0 family inet6
set interfaces ge-0/0/0 unit 0 family mpls
set interfaces ge-0/0/1 unit 0 family inet address 2.1.1.1/30
set interfaces ge-0/0/1 unit 0 family iso
set interfaces ge-0/0/1 unit 0 family inet6
set interfaces ge-0/0/1 unit 0 family mpls
set interfaces lo0 unit 0 family inet address 6.6.6.6/32
set interfaces lo0 unit 0 family iso address 49.0000.6666.0000.0000.00
set routing-options router-id 6.6.6.6
set routing-options autonomous-system 65400
set protocols isis source-packet-routing srgb start-label 30000
set protocols isis source-packet-routing srgb index-range 1000
set protocols isis source-packet-routing node-segment ipv4-index 200
set protocols isis level 1 disable
set protocols isis level 2 wide-metrics-only
set protocols isis interface ge-0/0/0.0 point-to-point
set protocols isis interface ge-0/0/1.0 point-to-point
set protocols isis interface lo0.0 passive
set protocols mpls interface ge-0/0/0.0
set protocols mpls interface ge-0/0/1.0

PE2

set chassis network-services enhanced-ip
set interfaces ge-0/0/0 unit 0 family inet address 2.1.1.2/30
set interfaces ge-0/0/0 unit 0 family iso
set interfaces ge-0/0/0 unit 0 family inet6
set interfaces ge-0/0/0 unit 0 family mpls
set interfaces ge-0/0/1 unit 0 family inet6 address 2ab5:0425:2ca1::0567:5673:23b4/127
set interfaces lo0 unit 0 family inet address 7.7.7.7/32
set interfaces lo0 unit 0 family iso address 49.0000.7777.0000.0000.00
set interfaces lo0 unit 0 family mpls
set policy-options policy-statement BGPv6 from family inet6
set policy-options policy-statement BGPv6 from protocol bgp
set policy-options policy-statement BGPv6 then accept
set policy-options policy-statement V6 from family inet6
set policy-options policy-statement V6 from protocol bgp
set policy-options policy-statement V6 from protocol direct
set policy-options policy-statement V6 then accept
set policy-options policy-statement next-hop-self then next-hop self
set routing-options router-id 7.7.7.7
set routing-options autonomous-system 65400
set protocols bgp group CE1 type external
set protocols bgp group CE1 local-address 2ab5:0425:2ca1::0567:5673:23b4
set protocols bgp group CE1 family inet6 unicast
set protocols bgp group CE1 export BGPv6
set protocols bgp group CE1 peer-as 65003
set protocols bgp group CE1 neighbor 2ab5:0425:2ca1::0567:5673:23b5
set protocols bgp group V6TUNNEL type internal
set protocols bgp group V6TUNNEL local-address 7.7.7.7
set protocols bgp group V6TUNNEL family inet6 labeled-unicast explicit-null
set protocols bgp group V6TUNNEL export next-hop-self
set protocols bgp group V6TUNNEL export V6
set protocols bgp group V6TUNNEL neighbor 5.5.5.5
set protocols isis source-packet-routing srgb start-label 30000
set protocols isis source-packet-routing srgb index-range 1000
set protocols isis source-packet-routing node-segment ipv4-index 300
set protocols isis level 1 disable
set protocols isis level 2 wide-metrics-only
set protocols isis interface ge-0/0/0.0 point-to-point
set protocols isis interface lo0.0 passive
set protocols mpls ipv6-tunneling
set protocols mpls interface ge-0/0/0.0

Routes are now being learned from the other CE device and IPv6 connectivity is up between the 2 sites.

Leave a Reply

Your email address will not be published. Required fields are marked *