Juniper vMX – Inter-AS BGP L2VPN Option B

Slight difference to Option A topology. Still running Segment Routing in AS65200 but AS65400 is now running RSVP. Great article linked below from Chris Parker who explains Option B in more detail (click on Network Fun Times link). OSPF configured on the 2 Cisco CE devices.

Network Fun Times Inter-AS Option B

PE1

set chassis network-services enhanced-ip
set interfaces ge-0/0/0 vlan-tagging
set interfaces ge-0/0/0 encapsulation flexible-ethernet-services
set interfaces ge-0/0/0 unit 123 encapsulation vlan-ccc
set interfaces ge-0/0/0 unit 123 vlan-id 123
set interfaces ge-0/0/2 unit 0 family inet address 1.1.1.1/30
set interfaces ge-0/0/2 unit 0 family iso
set interfaces ge-0/0/2 unit 0 family mpls
set interfaces lo0 unit 0 family inet address 5.5.5.5/32
set interfaces lo0 unit 0 family iso address 49.0000.5555.5555.5555.00
set interfaces lo0 unit 0 family mpls
set routing-options router-id 5.5.5.5
set routing-options autonomous-system 65200
set protocols mpls interface ge-0/0/2.0
set protocols mpls interface lo0.0
set protocols bgp group INTERNAL type internal
set protocols bgp group INTERNAL local-address 5.5.5.5
set protocols bgp group INTERNAL family l2vpn signaling
set protocols bgp group INTERNAL export NHS
set protocols bgp group INTERNAL neighbor 6.6.6.6
set protocols isis source-packet-routing srgb start-label 33000
set protocols isis source-packet-routing srgb index-range 1000
set protocols isis source-packet-routing node-segment ipv4-index 20
set protocols isis level 1 disable
set protocols isis level 2 wide-metrics-only
set protocols isis interface ge-0/0/2.0 point-to-point
set protocols isis interface lo0.0 passive
set policy-options policy-statement NHS term 1 from protocol bgp
set policy-options policy-statement NHS term 1 then next-hop self
set routing-instances L2VPN instance-type l2vpn
set routing-instances L2VPN interface ge-0/0/0.123
set routing-instances L2VPN route-distinguisher 5.5.5.5:123
set routing-instances L2VPN vrf-target target:65200:123
set routing-instances L2VPN protocols l2vpn encapsulation-type ethernet-vlan
set routing-instances L2VPN protocols l2vpn site L2VPN site-identifier 1
set routing-instances L2VPN protocols l2vpn site L2VPN interface ge-0/0/0.123

P1

set chassis network-services enhanced-ip
set interfaces ge-0/0/0 unit 0 family inet address 1.1.1.2/30
set interfaces ge-0/0/0 unit 0 family iso
set interfaces ge-0/0/0 unit 0 family mpls
set interfaces ge-0/0/1 unit 0 family inet address 2.2.2.1/30
set interfaces ge-0/0/1 unit 0 family iso
set interfaces ge-0/0/1 unit 0 family mpls
set interfaces lo0 unit 0 family inet address 6.6.6.6/32
set interfaces lo0 unit 0 family iso address 49.0000.6666.6666.6666.00
set interfaces lo0 unit 0 family mpls
set routing-options router-id 6.6.6.6
set routing-options autonomous-system 65200
set protocols mpls interface ge-0/0/0.0
set protocols mpls interface ge-0/0/1.0
set protocols mpls interface lo0.0
set protocols bgp group INTERNAL type internal
set protocols bgp group INTERNAL local-address 6.6.6.6
set protocols bgp group INTERNAL family l2vpn signaling
set protocols bgp group INTERNAL export NHS
set protocols bgp group INTERNAL cluster 6.6.6.6
set protocols bgp group INTERNAL neighbor 5.5.5.5
set protocols bgp group INTERNAL neighbor 33.33.33.33
set protocols isis source-packet-routing srgb start-label 33000
set protocols isis source-packet-routing srgb index-range 1000
set protocols isis source-packet-routing node-segment ipv4-index 25
set protocols isis level 1 disable
set protocols isis level 2 wide-metrics-only
set protocols isis interface ge-0/0/0.0 point-to-point
set protocols isis interface ge-0/0/1.0 point-to-point
set protocols isis interface lo0.0 passive
set policy-options policy-statement NHS term 1 from protocol bgp
set policy-options policy-statement NHS term 1 then next-hop self

ASBR1

set chassis network-services enhanced-ip
set interfaces ge-0/0/0 unit 0 family inet address 2.2.2.2/30
set interfaces ge-0/0/0 unit 0 family iso
set interfaces ge-0/0/0 unit 0 family mpls
set interfaces ge-0/0/1 unit 0 family inet address 10.33.33.1/30
set interfaces ge-0/0/1 unit 0 family mpls
set interfaces lo0 unit 0 family inet address 33.33.33.33/32
set interfaces lo0 unit 0 family iso address 49.0000.3333.3333.0000.00
set interfaces lo0 unit 0 family mpls
set routing-options router-id 33.33.33.33
set routing-options autonomous-system 65200
set protocols mpls interface ge-0/0/0.0
set protocols mpls interface lo0.0
set protocols mpls interface ge-0/0/1.0
set protocols bgp group INTERNAL type internal
set protocols bgp group INTERNAL local-address 33.33.33.33
set protocols bgp group INTERNAL family l2vpn signaling
set protocols bgp group INTERNAL export NHS
set protocols bgp group INTERNAL neighbor 6.6.6.6
set protocols bgp group AS65400 type external
set protocols bgp group AS65400 family l2vpn signaling
set protocols bgp group AS65400 peer-as 65400
set protocols bgp group AS65400 neighbor 10.33.33.2
set protocols isis source-packet-routing srgb start-label 33000
set protocols isis source-packet-routing srgb index-range 1000
set protocols isis source-packet-routing node-segment ipv4-index 30
set protocols isis interface ge-0/0/0.0 point-to-point
set protocols isis interface lo0.0 passive
set policy-options policy-statement NHS term 1 from protocol bgp
set policy-options policy-statement NHS term 1 then next-hop self

ASBR2

set chassis network-services enhanced-ip
set interfaces ge-0/0/0 unit 0 family inet address 10.33.33.2/30
set interfaces ge-0/0/0 unit 0 family mpls
set interfaces ge-0/0/1 unit 0 family inet address 4.4.4.1/30
set interfaces ge-0/0/1 unit 0 family iso
set interfaces ge-0/0/1 unit 0 family mpls
set interfaces lo0 unit 0 family inet address 7.7.7.7/32
set interfaces lo0 unit 0 family iso address 49.0000.7777.7777.7777.00
set interfaces lo0 unit 0 family mpls
set routing-options router-id 7.7.7.7
set routing-options autonomous-system 65400
set routing-options resolution
set protocols rsvp interface ge-0/0/1.0
set protocols rsvp interface lo0.0
set protocols mpls label-switched-path PE2 to 8.8.8.8
set protocols mpls interface ge-0/0/1.0
set protocols mpls interface lo0.0
set protocols mpls interface ge-0/0/0.0
set protocols bgp group INTERNAL type internal
set protocols bgp group INTERNAL local-address 7.7.7.7
set protocols bgp group INTERNAL family l2vpn signaling
set protocols bgp group INTERNAL export NHS
set protocols bgp group INTERNAL neighbor 9.9.9.9
set protocols bgp group AS65200 type external
set protocols bgp group AS65200 family l2vpn signaling
set protocols bgp group AS65200 peer-as 65200
set protocols bgp group AS65200 neighbor 10.33.33.1
set protocols isis level 1 disable
set protocols isis level 2 wide-metrics-only
set protocols isis interface ge-0/0/1.0 point-to-point
set protocols isis interface lo0.0 passive
set policy-options policy-statement NHS term 1 from protocol bgp
set policy-options policy-statement NHS term 1 then next-hop self

P2

set chassis network-services enhanced-ip
set interfaces ge-0/0/0 unit 0 family inet address 4.4.4.2/30
set interfaces ge-0/0/0 unit 0 family iso
set interfaces ge-0/0/0 unit 0 family mpls
set interfaces ge-0/0/1 unit 0 family inet address 5.5.5.1/30
set interfaces ge-0/0/1 unit 0 family iso
set interfaces ge-0/0/1 unit 0 family mpls
set interfaces fxp0 unit 0 family inet dhcp vendor-id Juniper-vmx-VM67309BAAF3
set interfaces lo0 unit 0 family inet address 9.9.9.9/32
set interfaces lo0 unit 0 family iso address 49.0000.9999.9999.0000.00
set interfaces lo0 unit 0 family mpls
set routing-options router-id 9.9.9.9
set routing-options autonomous-system 65400
set routing-options resolution rib bgp.l2vpn.0 resolution-ribs inet.0
set protocols rsvp interface ge-0/0/0.0
set protocols rsvp interface ge-0/0/1.0
set protocols rsvp interface lo0.0
set protocols mpls interface ge-0/0/0.0
set protocols mpls interface ge-0/0/1.0
set protocols mpls interface lo0.0
set protocols bgp group INTERNAL type internal
set protocols bgp group INTERNAL local-address 9.9.9.9
set protocols bgp group INTERNAL family l2vpn signaling
set protocols bgp group INTERNAL cluster 9.9.9.9
set protocols bgp group INTERNAL neighbor 7.7.7.7
set protocols bgp group INTERNAL neighbor 8.8.8.8
set protocols isis level 1 disable
set protocols isis level 2 wide-metrics-only
set protocols isis interface ge-0/0/0.0 point-to-point
set protocols isis interface ge-0/0/1.0 point-to-point
set protocols isis interface lo0.0 passive

PE2

set chassis network-services enhanced-ip
set interfaces ge-0/0/0 unit 0 family inet address 5.5.5.2/30
set interfaces ge-0/0/0 unit 0 family iso
set interfaces ge-0/0/0 unit 0 family mpls
set interfaces ge-0/0/1 vlan-tagging
set interfaces ge-0/0/1 encapsulation flexible-ethernet-services
set interfaces ge-0/0/1 unit 123 encapsulation vlan-ccc
set interfaces ge-0/0/1 unit 123 vlan-id 123
set interfaces lo0 unit 0 family inet address 8.8.8.8/32
set interfaces lo0 unit 0 family iso address 49.0000.8888.8888.8888.00
set interfaces lo0 unit 0 family mpls
set routing-options router-id 8.8.8.8
set routing-options autonomous-system 65400
set protocols rsvp interface ge-0/0/0.0
set protocols rsvp interface lo0.0
set protocols mpls label-switched-path ASBR2 to 7.7.7.7
set protocols mpls interface ge-0/0/0.0
set protocols mpls interface lo0.0
set protocols bgp group INTERNAL type internal
set protocols bgp group INTERNAL local-address 8.8.8.8
set protocols bgp group INTERNAL family l2vpn signaling
set protocols bgp group INTERNAL export NHS
set protocols bgp group INTERNAL neighbor 9.9.9.9
set protocols isis level 1 disable
set protocols isis level 2 wide-metrics-only
set protocols isis interface ge-0/0/0.0 point-to-point
set protocols isis interface lo0.0 passive
set policy-options policy-statement NHS term 1 from protocol bgp
set policy-options policy-statement NHS term 1 then next-hop self
set routing-instances L2VPN instance-type l2vpn
set routing-instances L2VPN interface ge-0/0/1.123
set routing-instances L2VPN route-distinguisher 8.8.8.8:123
set routing-instances L2VPN vrf-target target:65200:123
set routing-instances L2VPN protocols l2vpn encapsulation-type ethernet-vlan
set routing-instances L2VPN protocols l2vpn site L2VPN site-identifier 2
set routing-instances L2VPN protocols l2vpn site L2VPN interface ge-0/0/1.123

OSPF is now up on the 2 Cisco CE devices, confirming the layer 2 VPN is established.

Juniper vMX – Inter-AS L3VPN Option A

This topology uses option A and, as usual, 2 Cisco devices as CEs. BGP is used for routing between PEs & CEs. AS65200 is running Segment Routing and AS65400 LDP.

https://www.juniper.net/documentation/us/en/software/junos/vpn-l3/topics/topic-map/l3-vpns-interprovider.html#:~:text=Interprovider%20Layer%203%20VPN%20Option%20A%20provides%20interprovider%20VRF%2Dto,is%20the%20least%20scalable%20solution.

PE1

set chassis network-services enhanced-ip
set interfaces ge-0/0/0 unit 0 family inet address 10.1.1.1/24
set interfaces ge-0/0/2 unit 0 family inet address 1.1.1.1/30
set interfaces ge-0/0/2 unit 0 family iso
set interfaces ge-0/0/2 unit 0 family mpls
set interfaces lo0 unit 0 family inet address 5.5.5.5/32
set interfaces lo0 unit 0 family iso address 49.0000.5555.5555.5555.00
set interfaces lo0 unit 0 family mpls
set routing-options router-id 5.5.5.5
set routing-options autonomous-system 65200
set protocols mpls interface ge-0/0/2.0
set protocols mpls interface lo0.0
set protocols bgp group INTERNAL type internal
set protocols bgp group INTERNAL local-address 5.5.5.5
set protocols bgp group INTERNAL family inet-vpn unicast
set protocols bgp group INTERNAL export NHS
set protocols bgp group INTERNAL neighbor 6.6.6.6
set protocols isis source-packet-routing srgb start-label 33000
set protocols isis source-packet-routing srgb index-range 1000
set protocols isis source-packet-routing node-segment ipv4-index 20
set protocols isis level 1 disable
set protocols isis level 2 wide-metrics-only
set protocols isis interface ge-0/0/2.0 point-to-point
set protocols isis interface lo0.0 passive
set policy-options policy-statement NHS term 1 from protocol bgp
set policy-options policy-statement NHS term 1 then next-hop self
set routing-instances L3VPN instance-type vrf
set routing-instances L3VPN interface ge-0/0/0.0
set routing-instances L3VPN route-distinguisher 5.5.5.5:1
set routing-instances L3VPN vrf-target target:65200:1
set routing-instances L3VPN vrf-table-label
set routing-instances L3VPN protocols bgp group L3VPN type external
set routing-instances L3VPN protocols bgp group L3VPN as-override
set routing-instances L3VPN protocols bgp group L3VPN neighbor 10.1.1.254 peer-as 65444

P1

set chassis network-services enhanced-ip
set interfaces ge-0/0/0 unit 0 family inet address 1.1.1.2/30
set interfaces ge-0/0/0 unit 0 family iso
set interfaces ge-0/0/0 unit 0 family mpls
set interfaces ge-0/0/1 unit 0 family inet address 2.2.2.1/30
set interfaces ge-0/0/1 unit 0 family iso
set interfaces ge-0/0/1 unit 0 family mpls
set interfaces lo0 unit 0 family inet address 6.6.6.6/32
set interfaces lo0 unit 0 family iso address 49.0000.6666.6666.6666.00
set interfaces lo0 unit 0 family mpls
set routing-options router-id 6.6.6.6
set routing-options autonomous-system 65200
set protocols mpls interface ge-0/0/0.0
set protocols mpls interface ge-0/0/1.0
set protocols mpls interface lo0.0
set protocols bgp group INTERNAL type internal
set protocols bgp group INTERNAL local-address 6.6.6.6
set protocols bgp group INTERNAL family inet-vpn unicast
set protocols bgp group INTERNAL export NHS
set protocols bgp group INTERNAL cluster 6.6.6.6
set protocols bgp group INTERNAL neighbor 5.5.5.5
set protocols bgp group INTERNAL neighbor 33.33.33.33
set protocols isis source-packet-routing srgb start-label 33000
set protocols isis source-packet-routing srgb index-range 1000
set protocols isis source-packet-routing node-segment ipv4-index 25
set protocols isis level 1 disable
set protocols isis level 2 wide-metrics-only
set protocols isis interface ge-0/0/0.0 point-to-point
set protocols isis interface ge-0/0/1.0 point-to-point
set protocols isis interface lo0.0 passive
set policy-options policy-statement NHS term 1 from protocol bgp
set policy-options policy-statement NHS term 1 then next-hop self

ASBR1

set chassis network-services enhanced-ip
set interfaces ge-0/0/0 unit 0 family inet address 2.2.2.2/30
set interfaces ge-0/0/0 unit 0 family iso
set interfaces ge-0/0/0 unit 0 family mpls
set interfaces ge-0/0/1 unit 0 family inet address 10.33.33.1/30
set interfaces lo0 unit 0 family inet address 33.33.33.33/32
set interfaces lo0 unit 0 family iso address 49.0000.3333.3333.0000.00
set interfaces lo0 unit 0 family mpls
set routing-options router-id 33.33.33.33
set routing-options autonomous-system 65200
set protocols mpls interface ge-0/0/0.0
set protocols mpls interface lo0.0
set protocols bgp group INTERNAL type internal
set protocols bgp group INTERNAL local-address 33.33.33.33
set protocols bgp group INTERNAL family inet-vpn unicast
set protocols bgp group INTERNAL export NHS
set protocols bgp group INTERNAL neighbor 6.6.6.6
set protocols isis source-packet-routing srgb start-label 33000
set protocols isis source-packet-routing srgb index-range 1000
set protocols isis source-packet-routing node-segment ipv4-index 30
set protocols isis interface ge-0/0/0.0 point-to-point
set protocols isis interface lo0.0 passive
set policy-options policy-statement NHS term 1 from protocol bgp
set policy-options policy-statement NHS term 1 then next-hop self
set routing-instances L3VPN instance-type vrf
set routing-instances L3VPN interface ge-0/0/1.0
set routing-instances L3VPN route-distinguisher 33.33.33.33:1
set routing-instances L3VPN vrf-target target:65200:1
set routing-instances L3VPN protocols bgp group AS65400 type external
set routing-instances L3VPN protocols bgp group AS65400 neighbor 10.33.33.2 peer-as 65400

ASBR2

set chassis network-services enhanced-ip
set interfaces ge-0/0/0 unit 0 family inet address 10.33.33.2/30
set interfaces ge-0/0/1 unit 0 family inet address 4.4.4.1/30
set interfaces ge-0/0/1 unit 0 family iso
set interfaces ge-0/0/1 unit 0 family mpls
set interfaces lo0 unit 0 family inet address 7.7.7.7/32
set interfaces lo0 unit 0 family iso address 49.0000.7777.7777.7777.00
set interfaces lo0 unit 0 family mpls
set routing-options router-id 7.7.7.7
set routing-options autonomous-system 65400
set protocols mpls interface ge-0/0/1.0
set protocols mpls interface lo0.0
set protocols bgp group INTERNAL type internal
set protocols bgp group INTERNAL local-address 7.7.7.7
set protocols bgp group INTERNAL family inet-vpn unicast
set protocols bgp group INTERNAL export NHS
set protocols bgp group INTERNAL neighbor 9.9.9.9
set protocols isis level 1 disable
set protocols isis level 2 wide-metrics-only
set protocols isis interface ge-0/0/1.0 point-to-point
set protocols isis interface lo0.0 passive
set protocols ldp interface ge-0/0/1.0
set protocols ldp interface lo0.0
set policy-options policy-statement NHS term 1 from protocol bgp
set policy-options policy-statement NHS term 1 then next-hop self
set routing-instances L3VPN instance-type vrf
set routing-instances L3VPN interface ge-0/0/0.0
set routing-instances L3VPN route-distinguisher 7.7.7.7:1
set routing-instances L3VPN vrf-target target:65200:1
set routing-instances L3VPN protocols bgp group AS65200 type external
set routing-instances L3VPN protocols bgp group AS65200 neighbor 10.33.33.1 peer-as 65200

P2

set chassis network-services enhanced-ip
set interfaces ge-0/0/0 unit 0 family inet address 4.4.4.2/30
set interfaces ge-0/0/0 unit 0 family iso
set interfaces ge-0/0/0 unit 0 family mpls
set interfaces ge-0/0/1 unit 0 family inet address 5.5.5.1/30
set interfaces ge-0/0/1 unit 0 family iso
set interfaces ge-0/0/1 unit 0 family mpls
set interfaces lo0 unit 0 family inet address 9.9.9.9/32
set interfaces lo0 unit 0 family iso address 49.0000.9999.9999.0000.00
set interfaces lo0 unit 0 family mpls
set routing-options router-id 9.9.9.9
set routing-options autonomous-system 65400
set protocols mpls interface ge-0/0/0.0
set protocols mpls interface ge-0/0/1.0
set protocols mpls interface lo0.0
set protocols bgp group INTERNAL type internal
set protocols bgp group INTERNAL local-address 9.9.9.9
set protocols bgp group INTERNAL family inet-vpn unicast
set protocols bgp group INTERNAL export NHS
set protocols bgp group INTERNAL cluster 9.9.9.9
set protocols bgp group INTERNAL neighbor 7.7.7.7
set protocols bgp group INTERNAL neighbor 8.8.8.8
set protocols isis level 1 disable
set protocols isis level 2 wide-metrics-only
set protocols isis interface ge-0/0/0.0 point-to-point
set protocols isis interface ge-0/0/1.0 point-to-point
set protocols isis interface lo0.0 passive
set protocols ldp interface ge-0/0/0.0
set protocols ldp interface ge-0/0/1.0
set protocols ldp interface lo0.0
set policy-options policy-statement NHS term 1 from protocol bgp
set policy-options policy-statement NHS term 1 then next-hop self

PE2

set chassis network-services enhanced-ip
set interfaces ge-0/0/0 unit 0 family inet address 5.5.5.2/30
set interfaces ge-0/0/0 unit 0 family iso
set interfaces ge-0/0/0 unit 0 family mpls
set interfaces ge-0/0/1 unit 0 family inet address 11.1.1.1/24
set interfaces lo0 unit 0 family inet address 8.8.8.8/32
set interfaces lo0 unit 0 family iso address 49.0000.8888.8888.8888.00
set interfaces lo0 unit 0 family mpls
set routing-options router-id 8.8.8.8
set routing-options autonomous-system 65400
set protocols mpls interface ge-0/0/0.0
set protocols mpls interface lo0.0
set protocols bgp group INTERNAL type internal
set protocols bgp group INTERNAL local-address 8.8.8.8
set protocols bgp group INTERNAL family inet-vpn unicast
set protocols bgp group INTERNAL export NHS
set protocols bgp group INTERNAL neighbor 9.9.9.9
set protocols isis level 1 disable
set protocols isis level 2 wide-metrics-only
set protocols isis interface ge-0/0/0.0 point-to-point
set protocols isis interface lo0.0 passive
set protocols ldp interface ge-0/0/0.0
set protocols ldp interface lo0.0
set policy-options policy-statement NHS term 1 from protocol bgp
set policy-options policy-statement NHS term 1 then next-hop self
set routing-instances L3VPN instance-type vrf
set routing-instances L3VPN interface ge-0/0/1.0
set routing-instances L3VPN route-distinguisher 8.8.8.8:1
set routing-instances L3VPN vrf-target target:65200:1
set routing-instances L3VPN vrf-table-label
set routing-instances L3VPN protocols bgp group L3VPN type external
set routing-instances L3VPN protocols bgp group L3VPN as-override
set routing-instances L3VPN protocols bgp group L3VPN neighbor 11.1.1.254 peer-as 65444

The 2 CE devices will now have IP connectivity and you can see the respective routes have been learnt on both sides.

Juniper vMX – Carrier of Carriers EVPN VPLS

This lab is slightly different to the other Carrier of Carrier lab where LDP was used in each AS. In this lab, AS65200 is using LDP, AS65400 RSVP & AS65600 Segment Routing. 2 Cisco vIOS devices used as CE devices

https://www.juniper.net/documentation/us/en/software/junos/vpn-l3/topics/topic-map/l3-vpns-carrier-carrier.html

PE1

set interfaces ge-0/0/0 vlan-tagging
set interfaces ge-0/0/0 encapsulation vlan-vpls
set interfaces ge-0/0/0 unit 909 encapsulation vlan-vpls
set interfaces ge-0/0/0 unit 909 vlan-id 909
set interfaces ge-0/0/0 unit 909 family vpls
set interfaces ge-0/0/2 unit 0 family inet address 1.1.1.1/30
set interfaces ge-0/0/2 unit 0 family iso
set interfaces ge-0/0/2 unit 0 family mpls
set interfaces lo0 unit 0 family inet address 5.5.5.5/32
set interfaces lo0 unit 0 family iso address 49.0000.5555.5555.5555.00
set interfaces lo0 unit 0 family mpls
set routing-options router-id 5.5.5.5
set routing-options autonomous-system 65200
set protocols mpls interface ge-0/0/2.0
set protocols mpls interface lo0.0
set protocols bgp group AS65600 type external
set protocols bgp group AS65600 multihop
set protocols bgp group AS65600 local-address 5.5.5.5
set protocols bgp group AS65600 family evpn signaling
set protocols bgp group AS65600 peer-as 65600
set protocols bgp group AS65600 neighbor 11.11.11.11
set protocols bgp group INTERNAL type internal
set protocols bgp group INTERNAL local-address 5.5.5.5
set protocols bgp group INTERNAL family inet labeled-unicast resolve-vpn
set protocols bgp group INTERNAL neighbor 6.6.6.6
set protocols isis level 1 disable
set protocols isis level 2 wide-metrics-only
set protocols isis interface ge-0/0/2.0 point-to-point
set protocols isis interface lo0.0 passive
set protocols ldp interface ge-0/0/2.0
set protocols ldp interface lo0.0
set routing-instances vpls instance-type evpn
set routing-instances vpls interface ge-0/0/0.909
set routing-instances vpls route-distinguisher 5.5.5.5:909
set routing-instances vpls vrf-target target:65200:909
set routing-instances vpls protocols vpls site-range 1000
set routing-instances vpls protocols vpls no-tunnel-services
set routing-instances vpls protocols vpls site vpls-1 site-identifier 1
set routing-instances vpls protocols vpls site vpls-1 interface ge-0/0/0.909
set routing-instances vpls protocols evpn interface ge-0/0/0.909

ASBR1

set interfaces ge-0/0/0 unit 0 family inet address 1.1.1.2/30
set interfaces ge-0/0/0 unit 0 family iso
set interfaces ge-0/0/0 unit 0 family mpls
set interfaces ge-0/0/1 unit 0 family inet address 2.2.2.1/30
set interfaces ge-0/0/1 unit 0 family iso
set interfaces ge-0/0/1 unit 0 family mpls
set interfaces lo0 unit 0 family inet address 6.6.6.6/32
set interfaces lo0 unit 0 family iso address 49.0000.6666.6666.6666.00
set interfaces lo0 unit 0 family mpls
set routing-options router-id 6.6.6.6
set routing-options autonomous-system 65200
set protocols mpls interface ge-0/0/0.0
set protocols mpls interface lo0.0
set protocols bgp group INTERNAL type internal
set protocols bgp group INTERNAL local-address 6.6.6.6
set protocols bgp group INTERNAL family inet labeled-unicast
set protocols bgp group INTERNAL neighbor 5.5.5.5
set protocols bgp group AS65400 type external
set protocols bgp group AS65400 family inet labeled-unicast
set protocols bgp group AS65400 export PE1_LOOPBACK
set protocols bgp group AS65400 peer-as 65400
set protocols bgp group AS65400 neighbor 2.2.2.2
set protocols isis interface ge-0/0/0.0 point-to-point
set protocols isis interface lo0.0 passive
set protocols ldp interface ge-0/0/0.0
set protocols ldp interface lo0.0
set policy-options policy-statement PE1_LOOPBACK from route-filter 5.5.5.5/32 exact
set policy-options policy-statement PE1_LOOPBACK then accept

CoC ASBR1

set interfaces ge-0/0/0 unit 0 family inet address 2.2.2.2/30
set interfaces ge-0/0/0 unit 0 family iso
set interfaces ge-0/0/0 unit 0 family mpls
set interfaces ge-0/0/1 unit 0 family inet address 3.3.3.1/30
set interfaces ge-0/0/1 unit 0 family iso
set interfaces ge-0/0/1 unit 0 family mpls
set interfaces lo0 unit 0 family inet address 7.7.7.7/32
set interfaces lo0 unit 0 family iso address 49.0000.7777.7777.0000.00
set interfaces lo0 unit 0 family mpls
set routing-options router-id 7.7.7.7
set routing-options autonomous-system 65400
set protocols rsvp interface ge-0/0/1.0
set protocols rsvp interface lo0.0
set protocols mpls label-switched-path ASBR2 to 9.9.9.9
set protocols mpls interface ge-0/0/1.0
set protocols mpls interface lo0.0
set protocols bgp group AS65200 type external
set protocols bgp group AS65200 family inet labeled-unicast
set protocols bgp group AS65200 peer-as 65200
set protocols bgp group AS65200 neighbor 2.2.2.1
set protocols bgp group INTERNAL type internal
set protocols bgp group INTERNAL local-address 7.7.7.7
set protocols bgp group INTERNAL family inet labeled-unicast
set protocols bgp group INTERNAL neighbor 8.8.8.8
set protocols isis level 1 disable
set protocols isis level 2 wide-metrics-only
set protocols isis interface ge-0/0/1.0 point-to-point
set protocols isis interface lo0.0 passive

CoC Core

set interfaces ge-0/0/0 unit 0 family inet address 3.3.3.2/30
set interfaces ge-0/0/0 unit 0 family iso
set interfaces ge-0/0/0 unit 0 family mpls
set interfaces ge-0/0/1 unit 0 family inet address 4.4.4.1/30
set interfaces ge-0/0/1 unit 0 family iso
set interfaces ge-0/0/1 unit 0 family mpls
set interfaces lo0 unit 0 family inet address 8.8.8.8/32
set interfaces lo0 unit 0 family iso address 49.0000.8888.8888.0000.00
set interfaces lo0 unit 0 family mpls
set routing-options router-id 8.8.8.8
set routing-options autonomous-system 65400
set protocols rsvp interface ge-0/0/0.0
set protocols rsvp interface ge-0/0/1.0
set protocols rsvp interface lo0.0
set protocols mpls interface ge-0/0/0.0
set protocols mpls interface ge-0/0/1.0
set protocols mpls interface lo0.0
set protocols bgp group INTERNAL type internal
set protocols bgp group INTERNAL local-address 8.8.8.8
set protocols bgp group INTERNAL family inet labeled-unicast
set protocols bgp group INTERNAL cluster 8.8.8.8
set protocols bgp group INTERNAL neighbor 9.9.9.9
set protocols bgp group INTERNAL neighbor 7.7.7.7
set protocols isis level 1 disable
set protocols isis level 2 wide-metrics-only
set protocols isis interface ge-0/0/0.0 point-to-point
set protocols isis interface ge-0/0/1.0 point-to-point
set protocols isis interface lo0.0 passive

CoC ASBR2

set interfaces ge-0/0/0 unit 0 family inet address 4.4.4.2/30
set interfaces ge-0/0/0 unit 0 family iso
set interfaces ge-0/0/0 unit 0 family mpls
set interfaces ge-0/0/1 unit 0 family inet address 5.5.5.1/30
set interfaces ge-0/0/1 unit 0 family iso
set interfaces ge-0/0/1 unit 0 family mpls
set interfaces lo0 unit 0 family inet address 9.9.9.9/32
set interfaces lo0 unit 0 family iso address 49.0000.9999.9999.0000.00
set interfaces lo0 unit 0 family mpls
set routing-options router-id 9.9.9.9
set routing-options autonomous-system 65400
set protocols rsvp interface ge-0/0/0.0
set protocols rsvp interface lo0.0
set protocols mpls label-switched-path ASBR1 to 7.7.7.7
set protocols mpls interface ge-0/0/0.0
set protocols bgp group INTERNAL type internal
set protocols bgp group INTERNAL local-address 9.9.9.9
set protocols bgp group INTERNAL family inet labeled-unicast
set protocols bgp group INTERNAL neighbor 8.8.8.8
set protocols bgp group AS65600 type external
set protocols bgp group AS65600 family inet labeled-unicast
set protocols bgp group AS65600 peer-as 65600
set protocols bgp group AS65600 neighbor 5.5.5.2
set protocols isis level 1 disable
set protocols isis level 2 wide-metrics-only
set protocols isis interface ge-0/0/0.0 point-to-point
set protocols isis interface lo0.0 passive

ASBR2

set chassis network-services enhanced-ip
set interfaces ge-0/0/0 unit 0 family inet address 5.5.5.2/30
set interfaces ge-0/0/0 unit 0 family iso
set interfaces ge-0/0/0 unit 0 family mpls
set interfaces ge-0/0/1 unit 0 family inet address 6.6.6.1/30
set interfaces ge-0/0/1 unit 0 family iso
set interfaces ge-0/0/1 unit 0 family mpls
set interfaces lo0 unit 0 family inet address 10.10.10.10/32
set interfaces lo0 unit 0 family iso address 49.0000.1010.1010.0000.00
set interfaces lo0 unit 0 family mpls
set routing-options router-id 10.10.10.10
set routing-options autonomous-system 65600
set protocols mpls interface ge-0/0/1.0
set protocols mpls interface lo0.0
set protocols bgp group INTERNAL type internal
set protocols bgp group INTERNAL local-address 10.10.10.10
set protocols bgp group INTERNAL family inet labeled-unicast
set protocols bgp group INTERNAL neighbor 11.11.11.11
set protocols bgp group AS65400 type external
set protocols bgp group AS65400 family inet labeled-unicast
set protocols bgp group AS65400 export PE2_LOOPBACK
set protocols bgp group AS65400 peer-as 65400
set protocols bgp group AS65400 neighbor 5.5.5.1
set protocols isis source-packet-routing srgb start-label 55000
set protocols isis source-packet-routing srgb index-range 10000
set protocols isis source-packet-routing node-segment ipv4-index 1000
set protocols isis level 1 disable
set protocols isis level 2 wide-metrics-only
set protocols isis interface ge-0/0/1.0 point-to-point
set protocols isis interface lo0.0 passive
set policy-options policy-statement PE2_LOOPBACK from route-filter 11.11.11.11/32 exact
set policy-options policy-statement PE2_LOOPBACK then accept

PE2

set chassis network-services enhanced-ip
set interfaces ge-0/0/0 unit 0 family inet address 6.6.6.2/30
set interfaces ge-0/0/0 unit 0 family iso
set interfaces ge-0/0/0 unit 0 family mpls
set interfaces ge-0/0/1 vlan-tagging
set interfaces ge-0/0/1 encapsulation vlan-vpls
set interfaces ge-0/0/1 unit 909 encapsulation vlan-vpls
set interfaces ge-0/0/1 unit 909 vlan-id 909
set interfaces ge-0/0/1 unit 909 family vpls
set interfaces lo0 unit 0 family inet address 11.11.11.11/32
set interfaces lo0 unit 0 family iso address 49.0000.1111.1111.0000.00
set interfaces lo0 unit 0 family mpls
set routing-options router-id 11.11.11.11
set routing-options autonomous-system 65600
set protocols mpls interface ge-0/0/0.0
set protocols mpls interface lo0.0
set protocols bgp group INTERNAL type internal
set protocols bgp group INTERNAL local-address 11.11.11.11
set protocols bgp group INTERNAL family inet labeled-unicast resolve-vpn
set protocols bgp group INTERNAL neighbor 10.10.10.10
set protocols bgp group AS65200 multihop
set protocols bgp group AS65200 local-address 11.11.11.11
set protocols bgp group AS65200 family evpn signaling
set protocols bgp group AS65200 peer-as 65200
set protocols bgp group AS65200 neighbor 5.5.5.5
set protocols isis source-packet-routing srgb start-label 55000
set protocols isis source-packet-routing srgb index-range 10000
set protocols isis source-packet-routing node-segment ipv4-index 1100
set protocols isis level 1 disable
set protocols isis level 2 wide-metrics-only
set protocols isis interface ge-0/0/0.0 point-to-point
set protocols isis interface lo0.0 passive
set routing-instances vpls instance-type evpn
set routing-instances vpls interface ge-0/0/1.909
set routing-instances vpls route-distinguisher 11.11.11.11:909
set routing-instances vpls vrf-target target:65200:909
set routing-instances vpls protocols vpls site-range 1000
set routing-instances vpls protocols vpls no-tunnel-services
set routing-instances vpls protocols vpls site vpls-1 site-identifier 1
set routing-instances vpls protocols vpls site vpls-1 interface ge-0/0/1.909
set routing-instances vpls protocols evpn interface ge-0/0/1.909

The VPLS circuit will now be up and OSPF has been configured to the 2 Cisco CE devices to confirm this.

Juniper vMX – IPv6 Tunneling over SR

Quite a simple lab this one. A customer wants to establish IPv6 connectivity between 2 sites over our SR IPv4 core so IPv6 tunneling is required. 2 Cisco vIOS routers used as the CE devices.

https://www.juniper.net/documentation/us/en/software/junos/mpls/topics/topic-map/ipv6-o-ipv4-tunnels.html

PE1

set chassis network-services enhanced-ip
set interfaces ge-0/0/0 unit 0 family inet address 1.1.1.1/30
set interfaces ge-0/0/0 unit 0 family iso
set interfaces ge-0/0/0 unit 0 family inet6
set interfaces ge-0/0/0 unit 0 family mpls
set interfaces ge-0/0/1 unit 0 family inet6 address 2a45:0425:2ca1::0567:5673:23b4/127
set interfaces lo0 unit 0 family inet address 5.5.5.5/32
set interfaces lo0 unit 0 family iso address 49.0000.5555.0000.0000.00
set interfaces lo0 unit 0 family mpls
set policy-options policy-statement BGPv6 from family inet6
set policy-options policy-statement BGPv6 from protocol bgp
set policy-options policy-statement BGPv6 then accept
set policy-options policy-statement V6 from family inet6
set policy-options policy-statement V6 from protocol bgp
set policy-options policy-statement V6 from protocol direct
set policy-options policy-statement V6 then accept
set policy-options policy-statement next-hop-self then next-hop self
set routing-options router-id 5.5.5.5
set routing-options autonomous-system 65400
set protocols bgp group CE1 type external
set protocols bgp group CE1 local-address 2a45:0425:2ca1::0567:5673:23b4
set protocols bgp group CE1 family inet6 unicast
set protocols bgp group CE1 export BGPv6
set protocols bgp group CE1 peer-as 65001
set protocols bgp group CE1 neighbor 2a45:0425:2ca1::0567:5673:23b5
set protocols bgp group V6TUNNEL type internal
set protocols bgp group V6TUNNEL local-address 5.5.5.5
set protocols bgp group V6TUNNEL family inet6 labeled-unicast explicit-null
set protocols bgp group V6TUNNEL export next-hop-self
set protocols bgp group V6TUNNEL export V6
set protocols bgp group V6TUNNEL neighbor 7.7.7.7
set protocols isis source-packet-routing srgb start-label 30000
set protocols isis source-packet-routing srgb index-range 1000
set protocols isis source-packet-routing node-segment ipv4-index 100
set protocols isis level 1 disable
set protocols isis level 2 wide-metrics-only
set protocols isis interface ge-0/0/0.0 point-to-point
set protocols isis interface lo0.0 passive
set protocols mpls ipv6-tunneling
set protocols mpls interface ge-0/0/0.0

P1

set chassis network-services enhanced-ip
set interfaces ge-0/0/0 unit 0 family inet address 1.1.1.2/30
set interfaces ge-0/0/0 unit 0 family iso
set interfaces ge-0/0/0 unit 0 family inet6
set interfaces ge-0/0/0 unit 0 family mpls
set interfaces ge-0/0/1 unit 0 family inet address 2.1.1.1/30
set interfaces ge-0/0/1 unit 0 family iso
set interfaces ge-0/0/1 unit 0 family inet6
set interfaces ge-0/0/1 unit 0 family mpls
set interfaces lo0 unit 0 family inet address 6.6.6.6/32
set interfaces lo0 unit 0 family iso address 49.0000.6666.0000.0000.00
set routing-options router-id 6.6.6.6
set routing-options autonomous-system 65400
set protocols isis source-packet-routing srgb start-label 30000
set protocols isis source-packet-routing srgb index-range 1000
set protocols isis source-packet-routing node-segment ipv4-index 200
set protocols isis level 1 disable
set protocols isis level 2 wide-metrics-only
set protocols isis interface ge-0/0/0.0 point-to-point
set protocols isis interface ge-0/0/1.0 point-to-point
set protocols isis interface lo0.0 passive
set protocols mpls interface ge-0/0/0.0
set protocols mpls interface ge-0/0/1.0

PE2

set chassis network-services enhanced-ip
set interfaces ge-0/0/0 unit 0 family inet address 2.1.1.2/30
set interfaces ge-0/0/0 unit 0 family iso
set interfaces ge-0/0/0 unit 0 family inet6
set interfaces ge-0/0/0 unit 0 family mpls
set interfaces ge-0/0/1 unit 0 family inet6 address 2ab5:0425:2ca1::0567:5673:23b4/127
set interfaces lo0 unit 0 family inet address 7.7.7.7/32
set interfaces lo0 unit 0 family iso address 49.0000.7777.0000.0000.00
set interfaces lo0 unit 0 family mpls
set policy-options policy-statement BGPv6 from family inet6
set policy-options policy-statement BGPv6 from protocol bgp
set policy-options policy-statement BGPv6 then accept
set policy-options policy-statement V6 from family inet6
set policy-options policy-statement V6 from protocol bgp
set policy-options policy-statement V6 from protocol direct
set policy-options policy-statement V6 then accept
set policy-options policy-statement next-hop-self then next-hop self
set routing-options router-id 7.7.7.7
set routing-options autonomous-system 65400
set protocols bgp group CE1 type external
set protocols bgp group CE1 local-address 2ab5:0425:2ca1::0567:5673:23b4
set protocols bgp group CE1 family inet6 unicast
set protocols bgp group CE1 export BGPv6
set protocols bgp group CE1 peer-as 65003
set protocols bgp group CE1 neighbor 2ab5:0425:2ca1::0567:5673:23b5
set protocols bgp group V6TUNNEL type internal
set protocols bgp group V6TUNNEL local-address 7.7.7.7
set protocols bgp group V6TUNNEL family inet6 labeled-unicast explicit-null
set protocols bgp group V6TUNNEL export next-hop-self
set protocols bgp group V6TUNNEL export V6
set protocols bgp group V6TUNNEL neighbor 5.5.5.5
set protocols isis source-packet-routing srgb start-label 30000
set protocols isis source-packet-routing srgb index-range 1000
set protocols isis source-packet-routing node-segment ipv4-index 300
set protocols isis level 1 disable
set protocols isis level 2 wide-metrics-only
set protocols isis interface ge-0/0/0.0 point-to-point
set protocols isis interface lo0.0 passive
set protocols mpls ipv6-tunneling
set protocols mpls interface ge-0/0/0.0

Routes are now being learned from the other CE device and IPv6 connectivity is up between the 2 sites.